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1. Introduction 

1.1 Overview 
Softany WordToHelp is a help authoring tool that help you create HTML help(CHM), Web help 

and PDF easily and quickly. To make all of these, you only need to know how to use Microsoft 

Word. 

Create the document in Word, output the HTML Help, Web Help and PDF with WordToHelp. 

With the over 20 built-in templates, you can create professional looking help files without any 

HTML knowledge. 

1.2 Features 
Use Word document as source 

WordToHelp uses Word document as source file. This makes a big advantage on word 

processing because of the power of Word. 

Creates HTML Help 

Since Microsoft account to remove the support files of Winhelp from Windows Vista, HTML 

Help becomes the only choice of standard help system on Windows. So far it is supported by 

all versions of Windows after Windows 98.  

Creates Web Help 

Place your help system on web, so your clients can use PC, notebook, mobile phone, tablet PC, 

etc. 

 

Import HTML help to Word file 

WordToHelp allows you to import HTML help (.chm) files to create word files. So you can 

easily transfer your current project under other help authoring tool to WordToHelp.  

1.3 System Requirements 
        Windows XP/Vista/7/2003 operating system or above.  
        Internet Explorer 5.5 or later 
        Microsoft Word 2003 or later (HTML Help and Web Help output) 
        Microsoft Word 2007 or later (PDF output) 
        Intel Pentium 166MHz or above.   
        64MB memory.   
        At least 10MB hard disk space.  

http://en.wikipedia.org/wiki/Windows_Help
http://en.wikipedia.org/wiki/Microsoft_Compiled_HTML_Help
http://en.wikipedia.org/wiki/Microsoft_Compiled_HTML_Help
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2. Quick Start Tutorials 

2.1 Getting Started 

2.1.1 Using an existing Word file 
Create a new project 

1.      Use menu File > New to launch New project Wizard. 
2.      On the first step, set the position you want to save the project and the name of the 

project file (.wfw). Then click Next button. 

 
3.      On the second step, choose Select an existing Word file option and click Finish button. 
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4.      Select the Word document you want to use. 

For existing project 

If the project has already been created, you can click Source File > Select… or  button to 

select the Word document. 

2.1.2 Creating a new Word file 
Create a new project 

1.      Use menu File > New to launch New project Wizard. 

2.      On the first step, set the position you want to save the project and the name of the 

project file (.wfw). Then click Next button. 

3.      On the second step, choose Create a new Word file option and click Finish button. 

4.      Create a new Word document dialog appears.  

Refer to: Create a new Word document(See 3.1.7) 

For existing project 

If the project has already been created, you can click Source File > Create… button to launch 

this dialog. 

2.1.3 Creating Word file from a HTML Help 

(.chm) 
Create a new project 
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1.      Use menu File > New to launch New project Wizard. 

2.      On the first step, set the position you want to save the project and the name of the 

project file (.wfw). Then click Next button. 

3.      On the second step, choose Import HTML help file (.chm) option and click Finish button. 

4.      Import from CHM file dialog appears.  

Refer to: Import from CHM file dialog(See 3.1.8) 

For existing project 

If the project has already been created, you can click Source File > From CHM… button to 

launch this dialog. 

3. How to use 

3.1 Interface 

3.1.1 Source tab 

 

Select… 

Select the word document you want to use as the source file. It is the same as pressing . 

Create… 

WordToHelp helps you create a new Word document with a Table of Contents. 

From CHM… 

Clicking this button will launch Import from CHM file dialog(See 3.1.8). It helps you convert a 

HTML Help file (.chm) to a new Word document and then use this Word document as the 

source. 

Folder 

Clicking this button will open the folder where the source Word file is stored in and highlight 

the Word file. 

Open 

Clicking this button will open the source Word file with Microsoft Word. This helps you quickly 

open the document to edit. 

3.1.2 Common tab 
Title 

Set a common title that may be use in HTML help, Web Help and PDF format.  

Template 
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Set some options that effect both HTML Help and Web Help template. 

Navigation settings 

Set the appearance of the navigation. 

Footer string 

This string will replace the tag ($footer$) in template. It supports HTML. 

Previous button hint 

 

Next button hint 

 

3.1.3 HTML Help tab 
Compiled file 

Specify the path and file name of the output HTML Help file. 

Title 

Set the title of the HTML Help file. If you check “Same as project title”, HTML help will use 

common title. 

Language 

HTML Help is not a Unicode program so we have to specify the language. 

Charset 

Specify the page charset. In most cases after you choose the language, it will automatically 

select a corresponding charset. 

Appearance 

Set the appearance of the HTML help file. 

Design CHM style… 

This button will launch a Visual CHM designer. You can visually design the appearance of the 

HTML Help. 

Default icon 

Set the default icons of the HTML Help. 
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Page template 

Set the template that will apply to pages in the HTML Help. 

Choose 

Choose a built-in template. 

Edit 

Edit the current template. WordToHelp allows you to make some simple changes on the 

template such as color, font name and images etc. 

Import 

Import a template from other place. 

Export 

Export the current template to a folder. By this way, you can save your template or edit it with 

professional web page editors and then import back to WordToHelp.  

Page extension 

Set the page extension of the HTML Help. Default is “.htm”. 

Within HTML Help file each topic is a html file. Its extension may be “.html” or “.htm”.  

Output Context File 

Output Html Help Workshop project (hhp) 

3.1.4 Web Help tab 
Output folder 

Specify the folder where the Web Help will be outputted to. 

Title 

Set the title of the Web Help. If you check “Same as project title”, HTML help will use common 

title. 

HTML extension 

Specify the extension of all HTML files within the Web Help. 
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3.1.5 PDF tab 
PDF tab 

Specify the PDF file name and set initial view. 

3.1.6 Build tab 
On this tab, you can start the building by clicking Build button, click Open button to open the 

output file or click Folder button to launch Windows Explorer with highlighted output file 

name. 
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3.1.7 Create a new Word document dialog 
This dialog help you create a new Word document with an initial Table of Contents.  

In Commonly used titles list box, there are many titles that commonly used in help document. 

You can double-click the item you want to use to add it into Initial Table of Contents. By this 

way, you can quickly build the table of contents of you help document. 
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          Click  to the increase indent level or click  to decrease the indent level.  

          Click Load… button to load the Table of Contents from a text file. 

          Click Save… button to store the current Table of Contents into a text file.  

3.1.8 Import from CHM file dialog 
Import from CHM file dialog 

This tool help you import Compiled HTML help (.chm) into a new Word document and then set 

the Word file as the source. 
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3.1.9 Set Navigation dialog 
Set the Navigation appearance within the template. 

 

Blank space in the end of Start text and Delimiter is effective. 

End with the delimiter check box will be enabled after unchecking Include current topic check 

box. 

3.1.10 Visual CHM designer 
WordToHelp uses Visual CHM designer to design html help interface. You can click Design 

CHM Style… button on HTML Help tab to launch this dialog. 
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Use the panel at the bottom of the window to set the properties of the CHM window. The 

other elements in the interface (e.g. Menus, Toolbar) have no real functions. They only show 

you the window style visually. But there are some exceptions: 

1.     Move and resize this window to set the default position and size of the window.  

2.     Drag the splitter to set the width of the navigation pane on the left of the window.  

Asterisk (*) after some options means the properties cannot be shown visually. 

3.1.11 Choose built-in template dialog 
Clicking Page template > Choose… button on HTML Help tab or Web Help tab will launch this 

dialog. There are many professional templates in the list. You can choose a template that you 

like for your help system. 

NOTE:  The template list may have difference between HTML Help and Web Help, because 

some templates for one help format are not suitable for another help format. 
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3.1.12 Template Editor 
Clicking Page template > Edit… button on HTML Help tab or Web Help tab will launch this 

tool. This tool help you make some changes such as colors, fonts and images etc. on current 

template.  

 



Softany WordToHelp Help 

 15 

Replace image 

You can select an image to replace current one. The new image must be the same type as 

original image. 

Color 

When you are editing the source, clicking this button will help you insert a color value. e.g. 

#FFFFFF. 

Font 

When you are editing the source, clicking this button will help you insert a font name list.  

CSS code 

Insert commonly used CSS code. 

3.2 Word skills 

3.2.1 Create Word document with outline 
The Word document you want to use with WordToHelp must have a good organized 

Document Map. 

 

To see the Document Map: 

          In Word 2007 and earlier versions: View > Document Map. 
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          In Word 2010: View > Navigation Pane.  

Add a new heading 

Select the line and then: 

Set the style as Heading 1 to Heading 9. 

 

Set the level using this listbox under Outlining tab. 

 

Move the headings 

Word 2010 

Drag and drop the headings in navigation pane. 

 

All version of Word 

1.      Press ALT+CTRL+O to switch to Outline view. 

2.      Press ALT+SHIFT+9 to show all headings only. 

3.      Drag  or  before the headings to move them. 

Promote or demote 

Word 2010 
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Right-click the heading in Navigation pane and then choose Promote or Demote on popup 

menu. 

 

All version of Word 

1.      Press ALT+CTRL+O to switch to outline view. 

Or use button View > Outline 

 
2.      Press ALT+SHIFT+9 to show all headings only. 

  

3.      Stop the cursor to the heading. 

4.      Press ALT+SHIFT+LEFT to promote or press ALT+SHIFT+Right to demote. 

 

3.2.2 Insert index entry 
1.      Click anywhere on the heading that you want to add keyword to or its body text. You can 

also select the text you want to set as keyword. 
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2.      Press ALT+SHIFT+X to launch Mark Index Entry dialog. 

3.      On the dialog, enter Main entry and Subentry(optional). Main entry will add a main 

keyword. Subentry will add a sub-keyword under the main keyword. 

4.      Click Mark button to finish. 

 

You can also use References > Mark Entry to launch this dialog. (Word 2010 and 2007) 

 

3.2.3 Insert fields 
We can insert empty fields into headings or their body texts to control the behavior of the 

topics. 

  Press Ctrl+F9 to insert an empty field. 

  Press Alt+F9 to switch between all field codes and their results. 

Format: 

{property1=value1,property2=value2,…} 

Properties Description 

Omit Specify whether omit this heading. If set 

Omit=true, the heading and its subheadings 

will be omitted when the help files are 

created. 

ID Specify a fixed context ID. WordToHelp will 

create context IDs automatically when 



Softany WordToHelp Help 

 19 

outputing context files, but they will be 

changed if the document map is changed. To 

fix them, you can specify this properfy 

clearly. 

For example: {ID=100} 

FileName Specify the file name when this topic is 

produced to a single html file. (To create 

HTML help and Web help, it is necessary for 

WordToHelp to split the document to single 

html files by topics.) 

StaticVar Specify the static variable in context file. 

 

3.2.4 Insert a screenshot 
Word 2010 has introduced a built-in screenshot tool.  

 

1.      Click the document that you want to add the screenshot to. 

2.      On the Insert tab, in the Illustrations group, click Screenshot. 

3.      Follow the step. 

General Method 

1.      Press Print Screen key on keyboard to capture the entire screen or press the Alt + Print 

Screen key to capture the currently selected window. 

2.      Paste into your Word document. 
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If you only need a part of the screenshot, you can use Word picture tool to crop it after 

pasted to Word document. We recommand you use Paint to do it. 

1.     Open Paint. (Start > All Programs > Accessories > Paint) 

2.     Press Ctrl-V to paste the screenshot that you captured with Print Screen button. 

3.     Use Select tool  to select the area you want to use. 

4.     Press Ctrl-C to copy it. 

5.     Turn to Word. Press Ctrl-V paste to your document. 

Snipping Tool is another choice. To launch this tool click Start > All Programs > Accessories > 

Snipping Tool. This tool is only available in Windows Vista and Windows 7. 

 

3.2.5 Insert Flash into your document 
1.      Click Developer tab. If this tab do not appear in your Word, show it. See Show Developer 

tab on the Ribbon(See 3.2.6).  

2.      Click Legacy Tools button. 

3.      Click More Controls button. 

 
4.      Select Shockwave Flash Object on More Controls dialog and then click OK, 
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5.      Right-click the object and then choose Properties on the popup menu.  

 
6.      Set the properties. 



Softany WordToHelp Help 

 22 

 
  

NOTE:  The units of Height and Width are point. If you have pixel values, you need to 

convert them to point. 1 pixel = 0.75 point. For example: you want to set the Width as 

400 pixels, here you should enter 300. 

7.      Click Design Mode button on Developer tab. If you want to continue editing the 

properties, click this button again. 

 
8.      OK 
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3.2.6 Show Developer tab on the Ribbon 
For Word 2010 

1.      Start Word. 

2.      Click the File tab. 

3.      Click Options. 

 
4.      In the categories pane, click Customize Ribbon. 

5.      In the list of main tabs, select Developer. 

 
6.      Click OK to close the Options dialog box. 
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For Word 2007 

1.      Start Word. 

2.      Click the Microsoft Office Button . 

3.      Click Word Options. 

 
4.      In the categories pane, click Popular. 

5.      Select Show Developer tab in the Ribbon. 
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6.      Click OK to close the Options dialog box. 

4. Miscellaneous 

4.1 How to create a template 
The template is a html file that contains tags. The tags can be replaced with special 

information of each topic when WordToHelp makes pages.  

The tags that can be used in template:  

($title$)   The title of the topic.  

($content$)  The content of the topic. 

($navigation$)   Show topic path. 

($footer$) Show the footer information. 

($prev$)  The text link that links to the previous topic. 

($next$)  The text link that links to the next topic. 

How to create image Previous and Next link?  

Prepare images "btn_prev_n.xxx" , "btn_next_n.xxx"  ("xxx" can be gif, png and jpg. ) and 

place them under the same folder as the template file. Edit the template file and Insert the 

image files into it.   
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If you want "gray" images when there is no link on the image, you should prepare other 

two images "btn_prev_g.xxx", "btn_next_g.xxx"  and place them under the same folder.  

 btn_prev_n.xxx  Normal Previous button. 

 btn_next_n.xxx   Normal Next button. 

 btn_prev_g.xxx  Gray Previous button. On the first topic, the Previous button will 

be gray, because there is no link on it. 

 btn_next_g.xxx  Gray Next button. On the last topic, the Next button will be gray, 

because there is no link on it. 

 

4.2 Command-line execution 
Usage: word2help [path]projectName [/B] [/BS]  

/B : Build the project 

/BS : Build the project in silent mode 

Example 1:  

Open project "c:\project\a.wfw" 

word2help "c:\project\a.wfw" 

  

Example 2:  

Open project "c:\project\a.wfw" and build the project in silent mode 

word2help "c:\project\a.wfw" /bs 

  

Note:  When working on command-line, WordToHelp will create a log file under the same 

folder as the project file. The log file has the same filename just as the project file except the 

extension. 

5. Using HTML Help and Web help 

5.1 About HTML Help 

5.1.1 Limited Unicode Support in HTML Help 
HTML Help can display Unicode-encoded content (by using the Microsoft Web Browser 

control). The use of different languages within the same topic is not supported, and can cause 

problems when using the table of contents and indexing features. The ability to index and 

search Unicode content is not currently supported. 

http://en.wikipedia.org/wiki/Microsoft_Compiled_HTML_Help 

http://en.wikipedia.org/wiki/Microsoft_Compiled_HTML_Help
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5.2 How to launch a CHM file 
For Win32 application, you can use API function ShellExecute to launch a CHM file.  

Example(delphi): 

uses SHELLAPI;  

ShellExecute(Application.Handle,'open', PChar('hh.exe'),PChar('filename.chm'), nil, 

SW_SHOW); 

  

Example(VB): 

Private Declare Function ShellExecute _ 

 Lib "shell32.dll" _ 

 Alias "ShellExecuteA" ( _ 

 ByVal hwnd As Long, _ 

 ByVal lpOperation As String, _ 

 ByVal lpFile As String, _ 

 ByVal lpParameters As String, _ 

 ByVal lpDirectory As String, _ 

 ByVal nShowCmd As Long) _ 

 As Long 

  

Private Sub Command2_Click() 

    ShellExecute 0, "open", "hh.exe", App.Path + "\filename.chm", "", 1 

End Sub 

For .NET application, you can use Help.ShowHelp to launch a CHM file.  

Example(C#): 

private void button1_Click(object sender, System.EventArgs e) 

  { 

  Help.ShowHelp(this, "filename.chm");  

  }  
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5.3 How to launch a chm file with a 

specified topic 
For Win32 application, you can use API function ShellExecute to launch a CHM file.  

Example(delphi):  

uses SHELLAPI; 

ShellExecute(Application.Handle,'open', 

PChar('hh.exe'),PChar('filename.chm::/TopicFileName.htm'), nil, SW_SHOW); 

  

Example(VB): 

Private Declare Function ShellExecute _ 

 Lib "shell32.dll" _ 

 Alias "ShellExecuteA" ( _ 

 ByVal hwnd As Long, _ 

 ByVal lpOperation As String, _ 

 ByVal lpFile As String, _ 

 ByVal lpParameters As String, _ 

 ByVal lpDirectory As String, _ 

 ByVal nShowCmd As Long) _ 

 As Long 

  

Private Sub Command1_Click() 

    ShellExecute 0, "open", "hh.exe", App.Path + "\filename.chm::/TopicFileName.htm", "", 1 

End Sub 

For .NET application, you can use Help.ShowHelp to launch a CHM file.  

Example(C#): 

private void button1_Click(object sender, System.EventArgs e) 

  { 

  Help.ShowHelp(this, "filename.chm", HelpNavigator.Topic, "TopicFileName.htm");  

  } 
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5.4 Integrating Web Help into your 

website 
To integrate Web Help into your existing web site: 

1. Build Web Help.  

2. Upload all of the files in the Web Help output folder into a folder on your web hosting. 

Generally we use FTP software to upload files.  

3. In your existing web pages, create hyperlinks that links to index.htm or index.html.  

For example:  

Assume your web site address is http://www.myweb.com and you have uploaded the Web 

help into folder /help. The web help address will be http://www.myweb.com/help/index.htm. 

If necessary, please consult your web designer and web hosting service provider. 

5.5 Linking to a special topic in the Web 

Help 
URL format:  

<Help address>/index.htm#page=<topic filename>   

For example:  

Assume the address of your Web help is http://www.myweb.com/help/index.htm , if you 

want to link to a topic "Introduction" which its file name is "introduction.htm", you can use 

this URL: http://www.myweb.com/help/index.htm#page=introduction.htm  

You can also right-click the right frame of your Web Help, choose Properties on the popup 

menu and then get the address from Address(URL) section. This address will automatically 

redirect to the URL above. 
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